So-net無料ブログ作成

今更Windowsで時刻同期 [Vista]

震災後、サーバーを止めているので、普段はドメインコントローラーに同期しているドメイン参加のクライアントの時刻が本体CMOSに依存して、狂っていきます。

ちょっと気になってしまったので、手を打つことにしました。

http://wiki.nothing.sh/page?NTP#jccc3012

ここに書いてある事を、実行するだけなのですが...

runas /user:administrator cmd.exe

で管理者権限でコマンドプロンプトを出して

> w32tm /config /syncfromflags:all /manualpeerlist:"NTPサーバーのFQDNまたはIPアドレスをスペースで区切って羅列" /update

します。
/syncfromflags:all
がキーで、これを指定しないと、コマンドの実行は成功するけど

> w32tm /query /status

しても、「ソース」が本体のCMOSクロックのまんまだったりします。
あとは

> sc config w32time start= delayed-auto

サービスに遅延起動登録してあげれば、再起動後、勝手にサービスが立ち上がります。
で、最後におまじない。

> w32tm /resync

そのうち、同期します:-)

Windows Update出来ず... [Vista]

まあ、済んだ事だから良いのだけど、会社で利用しているVaio Type-TのVistaが、Windows Update出来なくなりました。
事の発端は、9/11の朝っぱら、Updateを検知して、勝手にdownload開始したところまでは、良かったのだけど、なぜか途中でシステムが固まってしまいました。
でもって、ミーティング中だった事もあって、強制shutdown。
これがいけなかった模様...

以後、Windows Updateを継続しようとしても、色々エラーが出て、Update出来ない状態に。
色々善処したものの、最期は80073712のエラー。
http://support.microsoft.com/kb/947821
こいつを実行しようが、何しようがダメ...

諦めて、再インストールしました。
データ領域を分けておいたおかげで、バックアップコストは大して掛からず、楽ちんでしたが。

うーん、アップデート情報を管理するDBは、きちんと多重化して欲しいよな。
そもそも固まるのが悪いんだぞ! > Microsoft

RAID1E 300GB x3からRAID10 1TB x4へ [Vista]

RAID1E 300GB x3で構成していた450GBぐらいの領域が、何故か手狭になってしまったので、RAID10 1TB x4で一気に4倍にしてみました。

使ったのは、前にも
http://straycats.blog.so-net.ne.jp/2009-01-25-1
で紹介したClonezilla。

ちなみに、RAID1Eのままでよければ、4台で足りたのですが、残った1台は使われることがないswapになりかねないので、今回は他のマシン用のHDDを借りて移行しました。

まずは、元の領域を、新しい1TBのHDDにコピーします。
意外と早くて1時間弱で完了。
この状態で、RAIDの構成を組み替えて、コピーしたHDDからRAID10構成の領域に、コピーし直します。

気をつけることは、英語モードで動かすことと、boot loaderをglubで上書きさせないことと、verbose modeで動かすことぐらいかな。
日本語モードで動かすと、画面がくずれて、肝心な説明が読めません。

移行後のRAID10できちんと立ち上がれば、Windowsを再アクティベーションして、ボリュームサイズを拡張すると(「コントロールパネル」→「管理ツール」→「コンピュータの管理」→「ディスクの管理」)、一瞬で1.8TB強の領域になりました:-)
とりあえず、何の問題も発生せず。

しかーし、Diskeeper 2007 Professionalってボリュームサイズが768GBまでしかサポートしてないやん。
でも、デフラグ出来たけど...
さて、どーすっかなぁ~

Vista用Codecパッケージ [Vista]

http://straycats.blog.so-net.ne.jp/2008-06-01
で利用したソフトも辿れなくなっていたので、これまた捜索。

ありました、ありました:-)
http://fileforum.betanews.com/detail/Vista_Codec_Package/1159994557/1
http://fileforum.betanews.com/detail/Vista_Codec_Package_x64_Components/1159994557/2

Vista Businessとかお使いの方、AVCHDの再生が必要になった時は、これがあると便利です。

Vista 64-bit BusinessでAVCHD [Vista]

普段は映像編集しないし、別にソフトを買ってくりゃええやと思っているのだけど、見たいときに見れないのは、結構悲しい。
訳あって、AVCHDなストリームを確認したかったのだけど、Vista Businessには、この辺の再生環境無いんよね。
Windows Media Playerも、再生できませ~ん... とメッセージを表示してくれます。

そんなわけで、今回は
http://cowscorpion.com/Codec/AdvancedVistaCodecPackage.html
http://cowscorpion.com/Codec/VistaCodecsx64Components.html
をインストール。
64-bit版でも、無事に再生できました。

めでたしめでたし。

Vistaで画面キャプチャー再び [Vista]

以前
http://straycats.blog.so-net.ne.jp/2007-04-22
で書いたWindows Clippingsですが、CaptureXPに慣れきった身には、やっぱイマイチ使いにくいので、ちょっくら探し直したところ、便利なもの、見つけました!

WinShot
http://www.woodybells.com/winshot.html
っす。
ボタン一発とは行きませんが、なかなかいい感じぃ。

お試しあれ。

AT&T Global Network Client [Vista]

どーやら、本家では
http://www.attnetclient.com/
の如く、V7.2が出て、Vist 64-bitもよーやくサポートされたらしい。

が、某暗号化ソフトウェアは、まだサポートしてくれていないので、使うことになる日はまだまだ先かもしれない...

Vista 64-bitでunsigned driverを自動的に組み込むの巻 [Vista]

以前
http://straycats.blog.so-net.ne.jp/2008-01-03
で、いつのまにかVista 64-bitでVMware Server 1.xが動かなくなった対処の件は、書いたけど、Vista SP1の関係もあって、しばらくwatchしてました。
で、SP1も出て、適用したことだし、重たい腰をあげてやってみましたです。

まず、おさらい。
出所は
http://thebackroomtech.wordpress.com/2007/11/05/howto-disabling-driver-signing-in-windows-vista-64-bit/
です。
comment-1139
http://thebackroomtech.wordpress.com/2007/11/05/howto-disabling-driver-signing-in-windows-vista-64-bit/#comment-1139
に、コメントがあって

http://www.citadel.co.nr/readydriverplus/
に、わざわざUSB bootとかしなくても良いツールが出ておりました。

で、Multi bootしていなければ、ダウンロードしたツールをデフォルト設定でインストールするだけです。
おかげで、起動時に毎回F8を押してやる必要が無くなりました:-)

なお、設定を変えるには、一旦コントロールパネル経由でアンインストールしてあげます。
すんばらしい!!

VMware関連でWeb漁っててわかったこと [Vista]

普通の人にとっては、あまりたいしたことではないけど、どうやらWindows driverのデジタル署名代行取得サービスがあるらしい...
http://crystaldew.info/2007/09/26/%e3%83%87%e3%82%b8%e3%82%bf%e3%83%ab%e7%bd%b2%e5%90%8d%e3%81%ae%e3%81%be%e3%81%a8%e3%82%81%ef%bc%88vista-x64%e5%af%be%e5%bf%9c%ef%bc%89/

年間、3万円近くとられるのか...

あとは、おまけ。
VMwareをアンインストールする時、C:\Windows以下、vm*なVMwareのファイルらしきものが残っていたりする場合があります。
で、消そうにもOwnerがSYSTEMでAdministratorsにはフルコントロール権限が与えられていなかったりするのですが、こういうものは、所有権を奪った後に、権限を変更して、消し去りましょう。

えぢょ。


VMware 1.0.xがVista 64-bitで動かなくなった訳 [Vista]

やってくれるぜ、まいくろそふと。

いつの間にか、Windows UpdateやService Pack 1で、
http://blog.so-net.ne.jp/Straycats/2007-04-21
の対処を無効化してくれたらしい;-p

どっちかというと、F8押して、「ドライバ署名の強制を無効にする」を選択して起動するとlocalhostでVMが使えることは早々にわかったのだけど、回避策を探しまくってて、時間かかった...
結論から言うと、基本的には、毎回F8押せってことらしい。ざーけんな!

まあ、あとは、↓なことするか...
http://www.mydigitallife.info/2007/08/15/workaround-for-vista-cannot-load-low-level-driver-signing-issue/
http://www.mydigitallife.info/2006/11/23/remove-and-disable-windows-vista-evaluation-watermark-from-desktop/#comment-378694

はたまたUSBなディバイスからbootできるなら(遅くてもいいならFDをお使いください...)、↓で魔法のお手々に毎回F8押してもらうか...
http://thebackroomtech.wordpress.com/2007/11/05/howto-disabling-driver-signing-in-windows-vista-64-bit/

さらには、VMware Server 2.0 beta1を使うか、おとなしくVMware Playerを使うかだな...
うーむ、しばらく放置しよ。